4

My Hibiscus is loaded with buds, however they turn dark brown and never open. The leaves did have some signs of disease but we have sprayed the plant and it is looking better, however the buds are ready to open and then they turn brown. This only started about three weeks ago. I have had the plant three years and never had this issue. It is planted outdoors in full sun. Please let me know what I need to do to see the beautiful pink flowers again this summer.

  • You don't say where you are, so I can't check, but have you had hotter than usual sunny weather recently? Is the plant in a pot or in the ground? – Bamboo Aug 13 '18 at 23:22
  • I would say you need to start pruning. – Rob Aug 14 '18 at 16:35
  • Welcome! Thanks for such a detailed explanation! We really appreciate it! We could really use some picture of your plants! We can't give you the best help unless we can see what you're dealing with. Could you post the whole plant, and a close view of the unhealthy looking buds? Since our site's a bit different from some others, so I invite you to take the tour and look around our help center, We're looking forward to helping you! – Sue Saddest Farewell TGO GL Aug 15 '18 at 0:44
0

Has the plant been stressed by dehydration? Over-fertilization? Hot weather? Aphids or thrips? Double-flowered hibiscus are more sensitive too, FYI. All of these conditions can result in what you're seeing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.